Statically-linked core v0.12.2

dragon firedragon at gmail.com
Sun Jul 5 17:40:15 CEST 2015


Alexander Corn <mckay <at> doctormckay.com> writes:

> 
> 
> I’m having some issues with the statically-linked 0.12.2 core on 
CentOS 6. On startup, I get “QSslSocket: cannot call unresolved function 
d2i_X509”, and then Quassel says that it couldn’t find any certificates 
in the certificate file and that SSL support would be disabled.
>  
> All of my research seems to indicate that it can’t find OpenSSL, but 
my understanding is that since it’s statically-linked this shouldn’t be 
an issue since the necessary OpenSSL stuff would be inside the binary 
itself.
>  
> I also tried to build it myself but that didn’t get very far. The 
build fails with:
>  
> /home/mckay/quassel/0.12.2/quassel-
0.12.2/src/qtui/qtuiapplication.cpp: In member function âvirtual void 
QtUiApplication::saveState(QSessionManager&)â:
> /home/mckay/quassel/0.12.2/quassel-
0.12.2/src/qtui/qtuiapplication.cpp:188:30: error: invalid use of 
incomplete type âclass QSessionManagerâ
> In file included from /usr/local/Trolltech/Qt-
4.8.6/include/QtGui/QApplication:1:0,
>                  from /home/mckay/quassel/0.12.2/quassel-
0.12.2/src/qtui/qtuiapplication.h:27,
>                  from /home/mckay/quassel/0.12.2/quassel-
0.12.2/src/qtui/qtuiapplication.cpp:21:
> /usr/local/Trolltech/Qt-4.8.6/include/QtGui/qapplication.h:72:7: 
error: forward declaration of âclass QSessionManagerâ
> /home/mckay/quassel/0.12.2/quassel-
0.12.2/src/qtui/qtuiapplication.cpp: In member function âvoid 
QtUiApplication::resumeSessionIfPossible()â:
> /home/mckay/quassel/0.12.2/quassel-
0.12.2/src/qtui/qtuiapplication.cpp:197:27: error: âisSessionRestoredâ 
was not declared in this scope
> /home/mckay/quassel/0.12.2/quassel-
0.12.2/src/qtui/qtuiapplication.cpp:198:72: error: âsessionIdâ was not 
declared in this scope
>  
> Anyone have any ideas for what I’m doing wrong?
>  
> Alexander Corn
> "Dr. McKay"
> http://www.doctormckay.com
>  
> 
> 
> _______________________________________________
> quassel-users mailing list
> quassel-users <at> lists.quassel-irc.org
> http://lists.quassel-irc.org/mailman/listinfo/quassel-users
> 


I have an old centos box (Probably 5.x) running Quassel to fix this I 
had to install the 32bit openSSL libs "openssl.i686"

Also followed the FAQ entry to generate a cert.

http://quassel-irc.org/faq/cert


More information about the quassel-users mailing list